Web4Web.IT - Community Forums
Problema creazione nuovo database - Versione stampabile

+- Web4Web.IT - Community Forums (https://www.web4web.it/forum)
+-- Forum: Supporto Tecnico (/forum-21.html)
+--- Forum: DirectAdmin (/forum-22.html)
+--- Discussione: Problema creazione nuovo database (/thread-307.html)



Problema creazione nuovo database - rebelflag1985 - 31-08-2010 19:37

Ciao a tutti!

Ho il seguente problema: una volta effettuato l'accesso su phpMyAdmin, vorrei creare un nuovo database, ma non riesco perchè sotto il campo "Crea un nuovo database", c'è scritto in rosso "Nessun privilegio"...

Qualcuno sa dirmi come e dove devo modificare questi privilegi?


grazie!Vanish


RE: Problema creazione nuovo database - Might - 31-08-2010 23:01

Per creare un nuovo database, devi accedere tramite DirectAdmin, sezione Gestione MySQL


RE: Problema creazione nuovo database - rebelflag1985 - 02-09-2010 12:38

(31-08-2010 23:01)Might Ha scritto:  : https://www.web4web.it/forum/post-2597.html#pid2597Per creare un nuovo database, devi accedere tramite DirectAdmin, sezione Gestione MySQL

Ciao Might, si sapevo che si poteva fare tramite DirectAdmin, volevo solo capire perchè mi dava la scritta "Nessun privilegio" se provavo a farlo tramite phpMyAdmin Shy

cmq grazie per la risposta Smile


RE: Problema creazione nuovo database - rebelflag1985 - 07-09-2010 11:36

Tralascio un attimo il discorso sopra per via di un altro problema:

Sto cercando di installare TikiWiki (un CMS open source per gestire applicazioni web dinamiche), che necessità di un database su cui appoggiarsi.
Dopo aver copiato i files tramite FTP e aver creato il database da Gestione MySQL in DirectAdmin, procedo con l'esecuzione del file "tiki_install.php". Mi viene richiesto:

- Database type: inserisco "MySQL 4.1+"
- Host: inserisco "localhost"
- Database Name: inserisco il nome del database che ho creato
- Database User e Password: inserisco il nome e pass dell'utente che ho creato nel database (con tutti i permessi attivati)

Clicco su continua e mi appare il seguente messaggio di errore:

"Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) "
"Tiki cannot find a database connection"

Dove può essere il problema?Huh


RE: Problema creazione nuovo database - srpd - 07-09-2010 12:57

(07-09-2010 11:36)rebelflag1985 Ha scritto:  : https://www.web4web.it/forum/post-2613.html#pid2613- Host: inserisco "localhost"

Come host tu hai impostato localhost, ma non è corretto, dovresti usare invece sql.tuodominio.tld

Adesso poi non so se è necessario effettuare ancora le impostazioni di DNS come descritto qui: http://noc.web4web.it/maintenance/view.php?id=56 o ormai sono impostazioni di default, comunque o aspetti la conferma di qualcuno dello staff di Web4web, o se sei pratico e hai dimestichezza agisci di conseguenza.


RE: Problema creazione nuovo database - rebelflag1985 - 08-09-2010 20:21

(07-09-2010 12:57)srpd Ha scritto:  : https://www.web4web.it/forum/post-2614.html#pid2614Come host tu hai impostato localhost, ma non è corretto, dovresti usare invece sql.tuodominio.tld


Il consiglio è giusto, ma dovevo impostarlo come sql.tuodominio.it Wink

grazie srpd Thumbsup


RE: Problema creazione nuovo database - Gandalf - 09-09-2010 07:48

La modifica è già presente sulle nuove attivazioni, solo i clienti di vecchia data devono creare manualmente il record.

Restano da effettuare manualmente, per tutti, le variazioni agli access host degli utenti mysql. Purtroppo è una limitazione di DirectAdmin che non permette la messa in sicurezza di una configurazione multiserver (web da una parte, database da un altra) come nel nostro caso quindi siamo costretti a far procedere manualmente gli utenti per mantenere performance e sicurezza. (E' una variazioni di pochi secondi)