Web4Web.IT - Community Forums
Errori in dashboard dopo aggiornamento a wordpress 2.9 - Versione stampabile

+- Web4Web.IT - Community Forums (https://www.web4web.it/forum)
+-- Forum: Supporto Tecnico (/forum-21.html)
+--- Forum: Programmazione & Design (/forum-23.html)
+---- Forum: PHP (/forum-24.html)
+---- Discussione: Errori in dashboard dopo aggiornamento a wordpress 2.9 (/thread-110.html)



Errori in dashboard dopo aggiornamento a wordpress 2.9 - SbiellONE - 28-12-2009 14:43

Ciao a tutti! Dopo l'aggiornamento di wordpress mi ritrovo un sacco di errori del tutto simili a questo:

Warning: curl_setopt() [function.curl-setopt]: CURLPROTO_FILE cannot be activated when in safe_mode or an open_basedir is set in /home/w37102/domains/blog.vitauniversitaria.it/public_html/wp-includes/http.php on line 1302

Non so se la cosa sia dovuta all'aggiornamento del blog a wordpress 2.9 o al fatto che ho cambiato il dominio (prima era blog.vitauniversitaria.com) e magari c'è qualche riferimento alle vecchie directory (/home/w37102/domains/blog.vitauniversitaria.com/) che non riesco a trovare.

Ho già guardato sul db con
SELECT * FROM `wp_options` WHERE `option_value` LIKE '%vitauniversitaria.com%'
e cambiato tutti i valori con il .it


RE: Errori in dashboard dopo aggiornamento a wordpress 2.9 - Pirosauro - 28-12-2009 15:43

se non ricordo male dovrebbe essere un bug di php, fixato poi nella versione 5.2.12 (ovvero quella successiva a quella installata ora su w4w)
in questo caso credo basti aspettare che ritornino dalle ferie e aggiornino php Big Grin

per sicurezza, puoi pastare la riga 1302 (e qualcuna precedente) del file wp-includes/http.php?


RE: Errori in dashboard dopo aggiornamento a wordpress 2.9 - Gandalf - 29-12-2009 19:41

Io ho letto che è un bug di Wordpress, risolto dalla versione 2.9.1 ovvero la prossima che dovrà uscire.


RE: Errori in dashboard dopo aggiornamento a wordpress 2.9 - Pirosauro - 06-01-2010 21:32

che è appena uscita, quindi essendo stata drasticamente eliminata la riga che provocava l'errore, non dovresti aver più problemi dopo l'aggiornamento.


RE: Errori in dashboard dopo aggiornamento a wordpress 2.9 - Gandalf - 06-01-2010 21:39

Toh, han risolto con delicatezza...
Non funziona? Buttiamo via tutto....


RE: Errori in dashboard dopo aggiornamento a wordpress 2.9 - Pirosauro - 06-01-2010 23:38

sembrava quantomeno un tentativo di mantenere la compatibilità con versioni vecchie di php, quindi hanno tolto la struttura condizionale e lasciato solo il codice "fresco"