Espansione serverfarm: siglato accordo per raddoppio banda!


1 utente stanno visualizzando questa discussione: (0 membri, e 1 visitatore).
 
Valutazione discussione:
  • 0 voti - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Sito lento e problemi vari
» Problemi sul sito www.solonapolifans.it
03-09-2011, 15:30
Messaggio: #1
Sito lento e problemi vari
Un saluto a tutta la community di web4web.
Sono salvatore admin di http://www.solonapolifans.it

Scrivo questo topic perche ho dei problemi sul mio sito durante tutto l'arco della giornata.

Navigazione a volte buona,spesso lenta,a volte ci sono dei problemi di non raggiungibilita' del sito e schermata di errore nel browser.

Ho installato portale e forum phpbb3,entrambi generano poche queries anche perche ho installato pochissime mod.

Ho avuto 2 errori gravi:
SQL ERROR [ mysql4 ]

Too many connections [1040]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.


e l'altro e':

Blocked by mod_w4w_qos. Too many concurrent connection to this site. Please try later.

Vi posto i dati di google analitycs per quanto riguarda 1 mese di connessioni

8.613(277,84 Visite/giorno)

4.260
Visitatori unici assoluti

107.110
Visualizzazioni di pagina

Sono numeri bassi,e facilmente gestibili da un host condiviso.

Spero che mi diate un aiuto,visto che questi errori si sono verificati anche con sole 10 persone connesse al sito e non e' possibile avere problemi con un carico cosi basso di utenti
Trova tutti i messaggi di questo utente
03-09-2011, 23:45
Messaggio: #2
RE: Sito lento e problemi vari
(03-09-2011 15:30)metalmaster Ha scritto:  : https://www.web4web.it/forum/post-3479.html#pid3479Blocked by mod_w4w_qos. Too many concurrent connection to this site. Please try later.

significa che hai superato le (50, se ricordo bene) connessioni contemporanee.

Questo è un filtro che solitamente entra in funzione su siti molto trafficati o soggetti a piccoli attacchi di tipo DoS

Una buona lettura dei log Apache potrebbe darti risposta

[email protected] ha i poteri della super mucca
________
: http://it.linkedin.com/in/pirosauro - Website (offline)
Visita il sito web di questo utente Trova tutti i messaggi di questo utente
04-09-2011, 10:44
Messaggio: #3
RE: Sito lento e problemi vari
Ho aperto un ticket per chiedere delle verifiche e aiuto,ed inizialmente mi hanno risposto in modo molto evasivo,dicendomi di passare ad una soluzione piu' professionale(semidedicata).

Non credo pero' (visto le poche visite) che abbia bisogno di tale soluzione,anche perche se il tutto rallenta con appena 10 persone collegate il problema e' del server che mi ospita e non certamente il mio.

Non sono un tecnico e quindi piu di riportare quegli errori non posso fare,e credo che chi di dovere(i tecnici di web4web)debba verificare il tutto e cercare di trovare una soluzione.

In questo momento la navigazione risulta abbastanza fluida e per adesso non ho avuto errori.

Vi tengo aggiornati di questa situazione in questo topic.
Trova tutti i messaggi di questo utente
04-09-2011, 11:47 (Questo messaggio è stato modificato l'ultima volta il: 04-09-2011 11:51 da Pirosauro.)
Messaggio: #4
RE: Sito lento e problemi vari
(04-09-2011 10:44)metalmaster Ha scritto:  : https://www.web4web.it/forum/post-3481.html#pid3481anche perche se il tutto rallenta con appena 10 persone collegate il problema e' del server che mi ospita e non certamente il mio.

ma questo dato da dove l'hai preso?

[email protected] ha i poteri della super mucca
________
: http://it.linkedin.com/in/pirosauro - Website (offline)
Visita il sito web di questo utente Trova tutti i messaggi di questo utente
04-09-2011, 13:27
Messaggio: #5
RE: Sito lento e problemi vari
(04-09-2011 11:47)Pirosauro Ha scritto:  : https://www.web4web.it/forum/post-3481.html#pid3481anche perche se il tutto rallenta con appena 10 persone collegate il problema e' del server che mi ospita e non certamente il mio.

ma questo dato da dove l'hai preso?
In fondo al forum ho tutte le statistiche del sito
Trova tutti i messaggi di questo utente
04-09-2011, 14:42
Messaggio: #6
RE: Sito lento e problemi vari
già... ma se io apro 50 finestre di firefox sul tuo sito, risulto come un visitatore,ma di fatto faccio ben 50 richieste al server. Qui interviene il filtro di w4w che blocca le richieste al tuo sito (e solo al tuo).

Sono molto scettico sull'ipotesi da te formulata, su X4 ci sono pure io con 2 siti che non lamentano i tuoi problemi.

[email protected] ha i poteri della super mucca
________
: http://it.linkedin.com/in/pirosauro - Website (offline)
Visita il sito web di questo utente Trova tutti i messaggi di questo utente
04-09-2011, 18:30
Messaggio: #7
RE: Sito lento e problemi vari
quindi mi stai dicendo che probabilmente puo esserci qualcuno che apre piu sessioni del browser appositamente per far rallentare il tutto?

almeno vorrei sapere se c'e' qualcuno che si "diverte" a fare queste cose o se e' un problema di w4w.

Ho chiesto ad altre persone(su altri host) e mi hanno detto che su un condiviso riescono a gestire
circa 6000 visite giornaliere(150 in media al gg)senza avere rallentamenti di sorta.
Trova tutti i messaggi di questo utente
04-09-2011, 22:50 (Questo messaggio è stato modificato l'ultima volta il: 04-09-2011 22:53 da Pirosauro.)
Messaggio: #8
RE: Sito lento e problemi vari
dipende molto dall'applicativo oltre che dai "vicini". Con uno script fatto a regola d'arte si arriva a 12k senza problemi. Certo il picco di connessioni simultanee che rallenta/blocca il tutto può sempre presentarsi, ma per 30€ l'anno non si possono pretendere prestazioni da dedicato Big Grin

Il mio consiglio resta lo stesso: lettura log apache, visto che ci sono stati messi a disposizione...

p.s. più che sessioni browser, penso a qualche bot troppo vorace o a qualche download manager o ancora qualche lamer che ti punta uno stress tool

[email protected] ha i poteri della super mucca
________
: http://it.linkedin.com/in/pirosauro - Website (offline)
Visita il sito web di questo utente Trova tutti i messaggi di questo utente
04-09-2011, 23:50
Messaggio: #9
RE: Sito lento e problemi vari
capito.
intanto grazie per le spiegazioni che mi stai dando.

sono entrato nel pannello di controllo direct admin,come posso fare per reperire i log di agosto,visto che vedo salvati solo quelli di settembre?
Trova tutti i messaggi di questo utente
05-09-2011, 11:48
Messaggio: #10
RE: Sito lento e problemi vari
Da collega di admin forum posso quotare le spiegazioni di pirosauro.
Il forum che gestisco è ospitato su X1 e capita spesso anche a me di raggiungere il max connessioni concorrenti.
Il numero di utenti connessi contemporaneamente al forum non è indice affidabile per capire le connessioni che ci sono in quel momento.
Ad esempio da me può verificarsi l'errore con solo 40 utenti collegati ma può anche filare liscio con quasi 100 utenti collegati!!
Certe volte risulta impiantato per qualche decina di secondi e vedo che c'è un BOT che passa, secondo me aprono tante pagine contamporaneamente, troppe!
Ora sto valutando di passare al semidedicato, come ho scritto in un'altra discussione. Del resto finora X1 ha svolto egregiamente il lavoro per le dimensioni del forum ed il costo annuo. Ho anche tenuto abbastanza essenziale il forum senza fare aggiunte di altri servizi, questo mi ha permesso di tirare avanti per un bel po'.Yes

P.S. l'HardLimit di max connessioni contemporaneee è 35 (da log di X1)
Trova tutti i messaggi di questo utente


Altri utenti che stanno visualizzando questa discussione

1 utente stanno visualizzando questa discussione: (0 membri, e 1 visitatore).
 
Discussioni correlate...
Discussione: Autore Risposte: Letto: Ultimo messaggio
  Problemi trasferimento dominio Freed 1 6.791 22-02-2016 10:20
Ultimo messaggio: Gandalf
  Sito irrangiungibile Cox74 0 4.597 04-04-2015 17:31
Ultimo messaggio: Cox74
  Thunderbird: problemi invio posta emmedi 3 18.598 15-01-2015 11:31
Ultimo messaggio: emmedi
  Problemi aggiornamento Wordpress mattie 10 32.966 09-05-2014 11:10
Ultimo messaggio: Gandalf
  url temporanea sito massimocolle 1 8.883 15-05-2013 23:27
Ultimo messaggio: Gandalf
  Informazione sicurezza sito Royalfriends 2 11.538 12-01-2013 16:57
Ultimo messaggio: Royalfriends
  Problema errore 404 pagine mio sito Royalfriends 16 52.571 11-01-2013 16:59
Ultimo messaggio: Royalfriends
  Problema Joomla - Problemi connessioni esterne TrEVo 4 17.563 05-11-2012 13:12
Ultimo messaggio: TrEVo
  Problemi al database Marchintosh 2 10.361 08-09-2011 16:01
Ultimo messaggio: Gandalf
  Collegarsi al proprio sito senza impostare il dns per installare wordpress Delta12 4 17.382 11-07-2010 12:19
Ultimo messaggio: emmedi
 
Vai al forum:


Permessi di scrittura
Non puoi inserire nuove discussioni.
Non puoi inserire risposte.
Non puoi inserire allegati.
L' HTML è disattivato.
Il MyCode è attivato.
Le faccine sono attivato.
Il codice [img] è attivato.